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1 Introduction

AZ Interface (AZI) is tool and solution for implementing Java-like interface architecture in
LabVIEW projects.

Contrary to other solutions providing Java-like interface architecture, AZ Interface is simple
while fulfilling basic programming demands.

1.1 Conventions

1.1.1 Shortenings and abbreviators

Abbreviator Description

AZI AZ Interface

[aziName] Any name of AZI

BD Block Diagram

FP Front Panel

HD Hard Disk

[LabVIEW] Location of LabVIEW in this computer; for example

C:\Program Files (x86)\National Instruments\LabVIEW 2016\

[methodName] Any name of a method

OOP Object-Oriented Programming

RTE Run-Time Engine

SW Software; AZ Interface software

v. version

1.1.2 Font conventions

 Bold is used for anything that appears literally in a LabVIEW environment or in
LabVIEW  program. For example, for menu, labels that cannot be altered.

 Italic is used for terms and messages.

 Constant Width is used for values: paths, names, etc.
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 Constant Width Bold is used for values: paths, names, etc. that cannot or must
not be altered.

 [ ] – brackets surround selectable parts of paths, names, etc.

 Green Italic is used for private notes.

1.2 Versions

Version number consists of four values:

1. version - altered with major changes causing compatibility and/or conceptual issues;

2. subversion – altered with introduction of major changes;

3. fix – minor changes, f. ex. a bug fix or minor performance improvement;

4. build – has meaning only for developer; f. ex. allows accounting of development
packages, special assemblies, etc.

Altered version or subversion can cause a need in reading updated manual, while altered fix or
build does not affect the way of use.

1.2.1 Version 0.0.0-pre-alpha

First functional version of the toolkit.

The version was presented at European CLA summit in Madrid, 2018.

1.2.2 Version 1.0.0-alpha

The version basically differs from v.0.0.0.

This version is result of brainstorming at European CLA Summit 2018:

 first, the concept was presented as a regular lecture;

 second, pitfalls were extensively discussed/brainstormed with Stephen Loftus-Mercer,
National Instruments.

 third, the lecture was repeated and many other experts participated in brainstorming.

I highly appreciate contribution of all participants of these sessions /Andrei Zagorodni



6

1.2.2.1 Release 1.0.0.0

First public release of AZ Interface software.

1.2.2.2 Release 1.0.0.1

Public release including few small fixes.

Main fix: Improved HD folder selection algorithm for newly created AZ Interface.

1.2.3 Version 1.1.0-alpha

Reentrant execution of AZI methods is implemented. The reentrancy in this version was
"limited", see v.1.1 to v.2.1 manuals for concept if limited reentrancy.

1.2.4 Version 2.0.0-beta

Relationships between interfaces and interface-applying classes are altered. Each class
“knows” about applied interfaces while interfaces do not “know” about implementing classes.

Upgrading from version 1 to version 2 is described in section 4.4.

1.2.5 Version 2.1.0-beta/alpha

This version basically the same as v.2.0 with added Consistency tool (see chapter 5).

Main body of this version is beta while the Consistency tool is still alpha.

Note:

 There are differences between file structures of v.2.0 and v.2.1.

1.2.6 Version 2.2.0-beta/alpha

The version introduces improvements resulting from discussions at European CLA summit in
Krakow, 2019.

 Reentrancy limitations are solved.
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 Memory management is improved; role of interface method read_Object.vi is
changed (see section 6.4.3).

 Changes in custom code introduced by Consistency tool are bookmarked with tag
#TODO_AZI_autochange.

 Some bugs are identified ans fixed in Consistency tool.

 VI description fields are added in method-creating GUI-s.

Main body of this version is beta while the Consistency tool is still alpha.

Note:

 Versions 2.1 and earlier cannot be upgraded to v.2.2 with no effect on custom code.
See section 4.4 for details.

1.3 Concept of Interface in other languages

Concept of Interface was developed in some Object Oriented languages (OOP languages) to
substitute multiple inheritance. Probably the most known of these languages is Java.

Similarly to LabVIEW, a Java class can have only one parent class; i.e. class hierarchies have
tree-like structures. Java Interface allows creating "cross-links" between trees; i.e. simulate
multi-parent behavior. The concept is illustrated by Figure 1.

Figure 1 Interface in UML diagram

SubclassA and SubclassB belong to different hierarchical trees. InterfaceC unifies
common behavior of these classes with no effect on hierarchical positions of classes SuperA
and SuperB.

Java Interface provides an own data type allowing to work at corresponding abstraction layer.
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Java Interface can be considered as an Abstract Class having only abstract methods.
Attributes are not allowed in Interfaces. Otherwise InterfaceC behaves exactly in the
same way as any super-class.
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2 AZ Interface Background Ideas

2.1 Solutions

AZ Interface (AZI) utilizes capacity of Call By Reference node.

Each AZI is assembled as a native LabVIEW class. No class hierarchies are allowed between
AZI-s.

Relation between AZI and Class applying the interface is defined by adding the AZI in list of
Friends (Community scope) of the Class.

2.2 Features

AZI-s allow creating abstraction levels independent on hierarchical structures of classes.

AZI-s allow abstraction of functionality independently on implemented OOP model; i.e. same
methods of the same AZI can be applied in native LabVIEW classes, GOOP3 classes, GOOP4
classes, and G# classes.

LabVIEW code created with toolkit can be opened, edited and run without installation of the
toolkit. The code is not limited to LabVIEW  development environment; corresponding EXE-
files can be run under conventional LabVIEW RTE. However, developer must take care about
inclusion of invoked code in build specification (that is the same for any LabVIEW code
invoked with Call By Reference node).

2.3 Limitations

 The code is not imperative; for example inconsistency between terminal patterns is not
shown in Error list window. However such inconsistency can be resolved using
Consistency tool as described in Chapter 5.

 No hierarchy between AZ Interfaces can be established.

 Current version is tested only for My Computer branch of LabVIEW Project. Use of
the toolkit with other targets is implemented but not verified yet.

 Connector pane of AZI methods use terminal pattern 6x4x4x6 only. Altering the
terminal pattern would cause errors that are difficult to fix. Anyhow, using the same
pattern through the whole project is a good practice.

 Connector pane terminals of each AZI method should be assigned before the method is
applied in one of classes. Later changes could require significant efforts. Consistency
tool (see section 5.3) significantly simplifies this work but…
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3 System Requirements and Installation

3.1 Requirements

Current version of the toolkit is developed for LabVIEW 2016 and expected to be fully
functional with following versions of LabVIEW.

No additional package is required.

Ask me if you need the toolkit for an earlier version of LabVIEW. I can downgrade the code.

3.2 Installation

No installer is supplied with current version of the toolkit. Files must be manually copied in
corresponding LabVIEW directories.

Files belonging to older version of AZInterface must be deleted before installation.

3.2.1 File location

Files must be copied in different directories of LabVIEW. The table below refers to
[LabVIEW] directory that, for example to,

C:\Program Files (x86)\National Instruments\LabVIEW 2016\

Content of the following source directories must be copied into corresponding target
directories.

Supplied files Target LabVIEW directory

GProviders [LabVIEW]\resource\Framework\Providers\GProviders\

Providers [LabVIEW]\resource\Framework\Providers\

Project [LabVIEW]\resource\Framework\project\

help [LabVIEW]\help\

3.2.2 Recompiling

In some cases files of the toolkit must be recompiled after the copying; f. ex. VIs must be re-
saved accounting to new locations of sub-VIs.
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To do it open consequently three VIs. These VIs  are used only for manual installation. Ignore
messages concerning altered file locations. Order of opening could be important:

1. Open LabVIEW.

2. Open
[LabVIEW]\help\AZ Interfaces\_1_all_help_AZ_Interfaces.vi

3. Open
[LabVIEW]\resource\Framework\Providers\AZ_Interfaces\
_3_all_providers_AZ_Interfaces.vi

4. Open
[LabVIEW]\project\AZ Interfaces\
_4_all_project_AZ_Interfaces.vi

5. Click menu File > Save All.

6. Close all VI-s.

7. Restart LabVIEW.
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4 Primary Functions of the Toolkit

Note:

 When working with AZI and AZI-applying Class all involved files must available for
modifications. Remove write-protection from the AZI, the Class, and all their
members.

4.1 Creating AZI

1. Right-click the My Computer or any Virtual Folder and select menu AZ Interfaces
> Create AZ Interface.

2. Create Interface dialog will be opened.

3. Write name of new AZI, use other input fields if needed.

4. Click Create Interface.

Pink background indicates invalid input value; f. ex. invalid name, name in use, etc.

LabVIEW class will be created in selected location. Newly created AZI includes three
members:

 cast_to_Interface.vi – utility method called only by automatically created
methods of AZI-applying classes.

 method_refs.ctl – utility type definition that is part of AZI private data.

o The type definition is also used in automatically created methods of AZI-
applying classes.

 read_Object.vi – method is used for back-casting from AZI data type to data
type of particular class.

o If the method is used for back-casting, it should be followed with node To
More Specific Class.

o The method optionally destroys instance of AZI (but not instance of the class),
see section 6.4.3.
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4.2 Creating AZI method

1. Right-click the AZI class in LabVIEW project and select menu AZ Interfaces >
Create Interface method.

2. Write name of the method in the opened dialog, use other input fields if needed, and
click Create method button.

3. Open Front Panel of the newly created method.

4. Create controls and indicators and connect them to terminal pattern of the VI.

 Do not select another terminal pattern; only 6x4x4x6 pattern is supported.

 Do not disconnect existing terminals.

 ATTENTION: altering terminals (number of terminals, they assigning in terminal
pattern, data types) after overriding the method in AZI-applying class(es) will
cause a need in extensive manual work (see section 6.3). Consistency tool can
help but not solve all possible problems. Thus be careful at this step.

5. Do not edit Block Diagram of the method.

6. Optionally alter icon of the method, these changes will propagate in icons of
corresponding methods in AZI-applying classes.

7. Save the method.

8. Save the whole AZI (Select class in the project then right-click menu Save > Save All
(this Class) or select menu File > Save All).

Block Diagram (BD) of the newly created method (see Figure 2) contains default code and
terminals of user-created controls/indicators. This BD will be automatically altered when the
method is first overridden in any AZI-applying class (see section 4.3.2).

Figure 2 Example of newly created AZI method
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4.3 Applying AZI and AZI methods to Class

The same dialog is used for applying AZI to Class and for implementing AZI Method in the
Class.

1. Right-click any class in the project then select menu AZ Interfaces > Apply
Interface.

2. The dialog appears listing all available AZI-s (Figure 3). List interface methods is
populated with methods of AZI selected in list Interfaces.

Figure 3 GUI used for applying AZI to Class.

4.3.1 Applying AZI to Class

1. Select an item from list Interfaces. The list shows all AZI-s available in the Project.

 If selected AZI is already applied to the Class, button at bottom of the list is
disabled exposing text "Interface is applied". In this case select another AZI,
continue working with methods (section 4.3.2), or click Close.

2. Click button Apply interface.
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Applying AZI to a Class results in:

 The AZI is added in Class lists of Friends.

 New method is added to the Class:

o The method is named cast_to_[aziName].vi, where [aziName] is
name of the AZI.

o This method is used for casting of corresponding Object to type of the AZI. In
some sense the casting is similar to one performed by nodes To More Specific
Class or To More Generic Class.

o The method cast_to_[aziName].vi is initially broken. It will be
repaired automatically (its Block Diagram altered) when any AZI method is
applied in the Class (see section 4.3.2).

4.3.2 Implementing AZI methods in Class

1. Select an item from AZI list Interfaces (see Figure 3).

 List interface methods at right-hand shows methods available in this AZI.

 If selected AZI is not yet applied to the Class, button Apply interface at bottom of
the list is enabled. In this case click button Apply interface, select another AZI, or
click Close.

2. Select method in the list interface methods. Methods already applied in this Class are
disabled.

3. Click button Implement method.

Applying AZI method to a Class results in:

 The method is added in the Class:

o The method has necessary terminal pattern.

o Block Diagram of the method is initially empty. All coding of the method
must be performed manually.

 Utility method util_[aziName]_cls_[methodName].vi is created:

o Name of the utility method contains name of the AZI ([aziName]) and
name of the actual method ([methodName]).

o The utility method is created automatically and should not be altered.

 Block Diagram of cast_to_[aziName].vi method is automatically altered.

o The method is repaired if it was broken (the method being created is
initially broken).

 Block Diagram of corresponding AZI method is rewired if it was not done earlier.
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4.4 Upgrading to v.2

Version 2 of the toolkit cannot be used for further development of AZI-s created with
version 1. If a project contains v.1 AZI, right-click will open menu AZ Interfaces > Upgrade
Interface to v2.

Upgrading v.1. to v.2 does the following:

 Sets access scope of AZI method cast_to_Interface.vi to be Public.

 Empties AZI’s list of friends.

 Sets internal property of the AZI to be v.2.1.

 Upgrade of an AZI does not affect code of AZI-applying classes. However, some
members of these classes could be recompiled at next run.

Notes:

 There is no tool to upgrade AZI-s created in version 0. Anyhow v.0 was not released to
LabVIEW community.

 There is no need in upgrading from v.2.0 to v.2.1.

 Versions 2.1 and earlier cannot be upgraded to v.2.2 with no effect on custom code.
The reason is in differently implemented method read_Object.vi. Thus previous
versions can be upgraded only to v.2.1. V.2.2 of the SW works with AZInterfaces of
v.2.1 in the same way as with v.2.2 but do not allow creation of new reentrant methods
in the older version.
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5 Consistency Tool

Consistency tool provides help with solving discrepancies in AZInterface-containing projects.

5.1 Overview

Current version of Consistency tool (v.2.2) does the following :

 searches for AZI of old versions and updates the version,

 searches AZI-applying classes for non-overridden (absent) methods,

 searches inconsistency in method terminal patterns and helps in problem fixing.

The Consistency tool is available via menu Tools > AZ Interfaces >
AZ Interface Consistency tool…

GUI of the tool is shown in Figure 4.

Figure 4 AZ Interface Consistency tool

1 – Path to investigated LabVIEW project.

2 – Button Investigate/Stop.

3 – Button fixing selected error (see section 5.3). Text of the button varies.

4 – Button Close.



18

5 – 2D progress bar (see section 5.2.2).

6 – Category selector – radio buttons (see section 5.2.3).

8 – Inconsistency report table (see section 5.2.4).

5.2 GUI

5.2.1 Start investigation
Select LabVIEW project in field (1), see Figure 4, then click button Investigate (2).

Investigation can be interrupted with button Stop (2).

5.2.2 Progress indicator
2D progress indicator (5), see Figure 4,  shows progress through steps of investigation (up-
down) and through each step (left-right).

Besides it indicates fraction of inconsistent objects. Errors are indicated with red; warnings
are indicated with yellow bars.

5.2.3 Category selector
The selector (6), see Figure 4, allows paging through different categories of identified
inconsistencies. Found errors are described in inconsistency report table (7)

Each radio button of the selector is located against corresponding bar of progress
indicator (5). If no error or warning is found in the category (the bar is green), corresponding
radio button is disabled.

5.2.4 Inconsistency report table
The table (7), see Figure 4, presents errors belonging to one category. Errors are abbreviated
with letter "E"; warnings are abbreviated with letter "W". Categories of errors are selectable
as described in section 5.2.3. The errors are described in following sections.

5.3 Fixing errors

Consequent fixing of errors if recommended. This means: fix errors in interfaces first then
attend errors in classes.
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Some automatic fixing algorithms are straightforward. Others are described below.

5.3.1 Solving inconsistency in AZI method terminal pattern

The reported error is Terminal pattern differs from defined in method_refs.ctl.

Manual altering of AZI method terminal pattern inevitably causes inconsistency in all related
method and utilities. Type definition method_refs.ctl must be rectified first.

Consistency tool does the work. However, it can affect other members of the project.
Rescanning the project (see section 5.2.1) is highly recommended after such a fix.

5.3.2 Solving inconsistency in class method terminal pattern

The reported error is Terminal pattern does not match pattern of interface method.

Consistency tool alters terminal pattern accordingly to terminal pattern of the overridden AZI
method. I.e. controls and indicators of  the class methods are added/removed/replaced.

This could cause errors in BD of the method. To avoid confusions “old” controls and
indicators are not deleted but only disconnected from terminal pattern. “New” FP objects are
connected to terminal pattern but their terminals are not connected in BD. Thus
(ATTENTION!) developer must attend each altered class method and rewire terminals. For
the sake of convenience these terminals are bookmarked with tag
#TODO_AZI_autochange.
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6 How to Use

6.1 General example

Use of AZI-s can be illustrated by Block Diagram presented in Figure 5. Three classes are not
hierarchically related while all three apply the same AZI.

Objects belonging to three different OOP models are created (GOOP, G#, and Native
LVClass) then processed at common abstraction level of the AZI. Finally, the objects are cast
back to initial class types.

Figure 5 Example of AZI use.

Note:

 Value clear & close refs is default for input destroy Interface of AZI method
read_Object.vi. Thus all interface instances are destroyed in fourth step of
Figure 5.
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6.2 Working with class hierarchies

6.2.1 Sub-classes of AZI-implementing class

Any child of an AZI-applying class can override AZI methods overridden on parent class.
There is no need to apply the same AZI to each sub-class of the hierarchy.

6.2.2 Two AZI-implementing classes belonging to same hierarchy

A need in applying the same AZI to different classes of the same hierarchy is rare (see
section 6.2.1). At least I cannot identify such a need. However; if needed, this can be done
changing type of object terminals of all conflicting methods to Dynamic Dispatch.

6.3 Altering terminals of AZI method

6.3.1 Modifying terminals manually

Connector pane terminals of each AZI method should be assigned before the method is
applied in any AZI-applying class. However, a need in altering terminal signature could arise.
Terminal signatures of the following VIs must differ only by type of object terminals:

 AZI method must have object terminals of AZI type.

 Corresponding class methods must have object terminals of corresponding class type.

 Utility methods util_[aziName]_cls_[methodName].vi (see section 4.3.2)
must have object terminals of LabVIEW Object type.

 Corresponding element (VI Refnum) of method_refs.ctl (see section 4.1)
belonging to the AZI must have object terminals of LabVIEW Object type; i.e. the
element must have the same signature as utility method
util_[aziName]_cls_[methodName].vi.

6.3.2 Using Consistency Tool to modify terminals

 Create/remove/replace desirable control and indicators in AZI method.

 Save the method.

 Start Consistency tool and scan the project (button Investigate, (2) in Figure 4).
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 Select category Interface methods (selector (6) in Figure 4); then the AZI method
exposing error Terminal pattern differs from defined in method_refs.ctl.

 Fix the error (button (3) in Figure 4).

 Rescan the project (button Investigate, (2) in Figure 4).

 Select  category Class methods (selector (6) in Figure 4); then one of overriding class
methods exposing error Terminal pattern does not match pattern of interface method.

 Fix the error (button (3) in Figure 4).

 Open the method and rewire terminals in BD.

 Treat method of next class overriding the same AZI method;  and so on.

For  details see sections 5.3.1 and 5.3.2.

6.4 Instances of classes and interfaces

Note:

 Control of class and interface instancing is especially important for AZI-s, which
include reentrant methods. Missing to destroy instances of such AZI-s result in unused
refs left in memory. The destruction is needed even if reentrant methods were not
invoked in particular run of program.

6.4.1 Conventional instancing of classes

Conventional instancing/creating objects of by-value LVOOP class is illustrated in Figure 6.
New object (instance) is created with class constant or when class wire is branched.

Figure 6 Instancing of by-value class (LVOOP class)
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Contrary to by-value classes, instances of by-ref classes (GOOP or G#) are created only with
class constructor (see Figure 7). Forking of class wires copies only ref, which points to the
same instance of the class.

Figure 7 Instancing of by-ref class (GOOP or G# class)

6.4.2 Instancing of an AZI

Each AZI instance carries wrapped object of native or by-ref object and references to methods
of corresponding class. Thus AZI machinery is a by-ref solution. It means that one invocation
of class method cast_to_[aziName].vi creates one set of references pointing to class
methods that override interface methods.

Behavior of particular AZI instance differs for different OOP models. Figure 8 illustrates
instancing of AZI wrapping by-value class . Figure 9 shows instancing of AZI wrapping by-
ref class.

Figure 8 Instancing of a LVOOP class wrapped in AZI
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Figure 9 Instancing of a GOOP or G# class wrapped in AZI

6.4.3 Destroying instances of AZI

Because AZI uses references, each instance of AZI should be destroyed when not needed any
more. Method read_Object.vi with option clear & close refs is used for destruction.

Figure 10 illustrates the concept of destruction.

Figure 10 Concept of AZI destroying. Each instance created with method cast_to_[aziName].vi
should be destroyed using method read_Object.vi

Notes:

 Option clear (used in second step, Figure 10) does not close reference to class
methods. It is used for better memory management. This option is useful when
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working with by-value LVOOP classes because instances of these classes are created
when corresponding wire is forked.

 Input destroy Interface  defines "level of destruction": only read returns the object
without destroying instance of the interface; clear prevents from holding copy of the
object in memory that is specifically important for by-value LVOOP objects; clear &
close refs also closes refs to reentrant class methods preventing from memory leak
that can happen if the same class/interface pair is continuously cast in two or more
top-level processes.

6.5 Programming, good programming style

6.5.1 Using read_Object.vi

Method read_Object.vi has two purposes:

 conversion from AZI data type to data type of particular class,

 destroying instance of AZI.

The concept is illustrated in

Figure 11.

Figure 11 Using read_Object.vi
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6.5.2 Race conditions

An instance of AZI is only a wrapper around conventional object. Thus most cases of race
conditions should be resolved considering interactions between objects even if execution is
performed at AZI abstraction level.

However, destruction of AZI can cause race condition as shown in Figure 12. Upper flow in
this figure can be eventually completed before execution of other flows. If
read_Object.vi is executed before middle or/and bottom clone of MET.vi, these clones
cannot be run.

Figure 12 Race condition when destroying instance of AZI

The race condition can be resolved in different ways; f. ex. as shown in Figure 13.

Figure 13 Resolved race condition

6.5.3 Destroying AZI – good programming style

Using one call of read_Object.vi destructor per each call of
cast_to_[aziName].vi can be considered as good programming style.
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Note:

 Method read_Object.vi has disables automatic error handling. Thus the method
can be used even during development of the code; i.e. when some AZI methods are not
overridden in classes yet.
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7 About and Contacts

Figure 14 About

7.1 License Agreement

1 Acknowledgement

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING
THIS SOFTWARE. BY USING THIS FREEWARE VERSION YOU ACKNOWLEDGE
THAT YOU HAVE READ THIS LIMITED WARRANTY, UNDERSTAND IT, AND
AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU ALSO AGREE
THAT UNLESS YOU HAVE A DIFFERENT LICENSE AGREEMENT SIGNED BY
ANDREI ZAGORODNI YOUR USE OF THIS SOFTWARE INDICATES YOUR
ACCEPTANCE OF THIS LICENSE AGREEMENT AND WARRANTY. IF YOU DO NOT
AGREE TO THE TERMS OF THIS AGREEMENT, DELETE THE SOFTWARE FROM
ALL STORAGE MEDIA.
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2 License

This Freeware License Agreement (the "Agreement") is a legal agreement between you
("Licensee"), the end-user, and developer of AZ Interface Toolkit Andrei Zagorodni
("Developer") for the use of this software product ("Software"). Commercial as well as non-
commercial use is allowed. By using this Software or storing this program or parts of it on a
computer hard drive (or other media), you agree to be bound by the terms of this Agreement.
Provided that you verify that you are handling the original freeware version you are hereby
licensed to make as many copies of the freeware version of this Software and documentation.
You can alter this Software in any way but Developer does not carry any responsibility for
consequences.

If you alter and/or further develop this Software, documentation (including "help" and
"about") must include reference to original Software, name of its Developer and his contacts.

3 Limited Warranty and Disclaimer of Warranty

The AZ Interface Toolkit EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE
SOFTWARE. THIS SOFTWARE AND THE ACCOMPANYING FILES ARE PROVIDED
"AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OF
MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR
IMPLIED, OR NONINFRINGEMENT. THIS SOFTWARE IS NOT FAULT TOLERANT
AND SHOULD NOT BE USED IN ANY ENVIRONMENT WHICH REQUIRES THIS. NO
LIABILITY FOR DAMAGES. In no event shall AZ Interface Toolkit or its suppliers be
liable for any consequential, incidental or indirect damages whatsoever (including, without
limitation, damages for loss of business profits, business interruption, loss of business
information, or any other pecuniary loss) resulting of the use of or inability to use this
SOFTWARE EVEN IF the Software HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES. The entire risk resulting of use or performance of the SOFTWARE
remains with you.

4 Copyright

Copyright (c) by Andrei Zagorodni.

7.2 Contacts

Andrei Zagorodni

andrei.zagorodni@novatorsolutions.se

Please write AZI or AZ Interfaces in subject line.
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7.3 Support and communications

I shall appreciate feedback about bugs and bottlenecks identified in this SW.

I promise to read your emails and reply within reasonable time. However the project is
developed in my evenings and weekends. Thus the "reasonable time" will solely depend on my
work load.

You are free to modify code of the software. However I do not promise to support the modified
code.

Andrei Zagorodni


